Skip to main content

Posts

Showing posts from 2014

MBNA Balance Transfer Catch

The gotcha behind 0% credit card balance transfersAt the beginning of this year I have financed solar panels on a low interest line of credit with Scotiabank. In May I became aware of the 0.00% balance transfer option my MBNA credit card was offering and shortly afterwards I had the line of credit transferred to my credit card. I have done the home work, worked out the total costs (fees) to transfer over, called in to learn how things worked, confirmed there would be no interest charged, even confirmed that it will be ok for me to transfer any remaining balance back onto my line of credit before the promotion ended. Furthermore I recall explicitly asking what is the catch or hidden costs or anything else I should know about and was told there are none and no.When the first statement came it did show 0.00% promotional offer on the transfer and no interest, I felt smart, savvy, and proud to have saved a few hundred dollars in overall interest costs.But there is a gotcha that got me!Yest…

Stuck Salesforce Eclipse Force.com IDE Error

Clearing stale errors in salesforce EclipseWhen the default salesforce eclipse builders are enabled there is an intermittent issue (perhaps triggered by too many 'saves'?) where a complication error can not be cleared. Restarting Eclipse and right clicking and deleting the errors has no effect - the same error comes back after saving. However manually saving to the server by using the 'Right Click > Force.com > Save to Server' option does work. The only way I was able to clear this was to 'Right Click > Force.com > Refresh from Server' the file - this bug has been reported on Salesforce's Github. If you found this useful please comment or follow me on twitter .

Applying Git Patches in Eclipse IDE

Git Patch 'File does not exist' SolutionToday I needed to apply GIT formatted patches in Eclipse which led me to an hour or so long search on how to do it. Officially the help docs even state it's no possible however there is a Bug 358257 which is set to FIXED for this issue; but I was still getting the 'File does not exist' error. As shown in the above screen shot the solution is obvious, one must ignore leading patch segments until the files name path matches . This obvious solution escaped me and so I am posting this just in case you the reader have found yourself in the same situation as well.Feel free to comment or follow me on twitter @danielsoklows

Destination Path Too Long Fix

The file name(s) would be too long for the destination folder. Windows under the hood supports pathnames up to 32000 characters however due to some reasons - which I can only think are legacy support related - programs like 'Explorer' will choke on anything longer then about 260 characters during copy operations. This is very frustrating and can be major pain if you are re-installing your system and are keeping your program settings for example the Eclipse Workspace folder.In my quest for a solution I have found Terra Nova copy but my experience found it buggy - eventually I have discovered FastCopy utility by a Japanese programmer - it has nice right click integration and works well with Windows 8.1 even though has not been updated in a while. Drop a comment or follow me on twitter @danielsokolows if you found this post useful, and also considering donating to the author.

KickassTorrents Genre Advanced Search

How to create a RSS feed search for a specific genre As seen in the screenshot there is no direct way to specify a 'genre' search however after a bit of expirmenting I have found that there is a unsupported `genre:` parameter. Specifing it one can create a custom advance torrent search that will filter on movie genre - this is becaus you are then able to get the RSS feed of the search by appending `?rss=1` example: https://kickass.to/usearch/1080p%20user%3AanoXmous%20lang_id%3A2%20genre%3Asci-fi/?rss=1 If you have found this useful feel free to follow me @danielsokolows or post a comment.

RSS Feed Pagination kickass.to/usearch/1080p%20user%3AanoXmous%20lang_id%3A2%20genre%3Asci-fi/?rss=1 kickass.to/usearch/1080p%20user%3AanoXmous%20lang_id%3A2%20genre%3Asci-fi/2/?rss=1 kickass.to/usearch/1080p%20user%3AanoXmous%20lang_id%3A2%20genre%3Asci-fi/3/?rss=1

Run All Tests in Salesforce Org

How to run all tests in SalesforceBecause the location of this button is not obvious and because it took a number of searches to locate I am bloging this; the button is located on the 'Setup > Devleop > Apex Classes' page instead of where it should be: 'Apex Test Execution'. Feel free to comment or follow me on

Duplicate value found: duplicates value on record with id: <unknown>.

System.DmlException: Insert failed. First exception on row 0; first error: DUPLICATE_VALUE, duplicate value found: <unknown> duplicates value on record with id: <unknown>.The above error is triggered in the database layer and caused by a trigger or workflow outside of your main code of block that is bubbling this exception. This is rather difficult to track down especially if you are unfamiliar with the code, I am sharing my procedure in the hopes this saves you time - if you find this helpful drop me a line or follow me on twitter @danielsokolows. This error is caused by unique field constraint on the object, so the first step is to examine the object and locate the API names of all unique fieds. You can do this through SF direclty 'Setup < Customize &lt <object being inserted> &lt Fields' or by downloading the `src/objects` metadata information and searching for <unique>; I preffer the latter and actually download ALL matadata information f…

Illegal assignment from Id to SOBJECT

Eclipse IDE Salesforce Save error: Illegal assignment from Id to SOBJECT:Property__cThis is a straight forward error message once you understand the cause. I posting this as search results I found deal with the reverse of this situation `Illegal assignment from SObject:<Object> to Id. The solution is to reference using the `__r` which returns the actual SObject instead of `__c` which returns an `Id` ... globalDevelopment = tch.createAndInsertOpp(new Map {'RecordType' => 'project'}); // dev project mainProp = globalDevelopment.property__r; // must use `__r` to return actuall SObject ... If this post has helped do comment here or follow me on twitter @danielsokolows.

Eclipse IDE Outline 'Expand All'

How to expand all nodes in Outline viewThere is a minimize all button but no expand all, searching the net was not helpful right away but I did find the solution after about half hour - hence to save you time I have posted this. Pressing Numeric Keypad '*' character expands all the nodes of the currently focused tree view, note pressing 'Shift + 8' will not work. If you found this useful feel free to comment or follow me @danielsokolows

OneDrive Free Extra 0.5GB

Getting free online cloud spaceMicrosoft's OneDrive (formally SkyDrive) gives you 7GB free, however by setting up a Camera Roll (SkyDrive on your phone) you get an extra 3GB and you can further get 5GB for anyone you invite. The cool thing is that both the person inviting and invitee end up with an extra 0.5GB, so please use the below link and we both benefithttps://onedrive.live.com?invref=18c99e1843b58545&invsrc=90On a side note I must say I am mightily impressed with the social consolidation: LinkedIn, Facebook, Skype, Twitter, etc but that's a post for another day, thanks and hope this helps, @danielsokolows.

. Command line: hg -y showconfig ui.username, error code:

Mercurial Eclipse fresh install not workingSomeone dropped the ball on this one, yes the solution is obvious once it's obvious - but until then you will be pulling your hair out. After all you did just install the Mercurial Eclipse plugin from Eclipse Marketplace so it should just work? Well it didn't for me and neither did trying the latest snapshot builds - when restarting Eclipse I kept getting: The cause of this error is that there is no actual built in mercruial support in the plugin so one must have `hg` installed natively. The solution is to go to Mercurial download page, run the setup, and then restart your eclipse.If this has helped you feel free to follow me on Google+ or on twitter @danielsokolow or just say hello.

Eclipse IDE Horizontal Scrolling With a Mouse

System wide horizontal scrolling with Ctrl+ or Shift+ mouse wheelThere is an outstanding Bug 201984 to provide a horizontal scrolling mechanism within Eclipse for mouses without a tilt scroll wheel. Untill it's acutally implemented (please register and vote up the bug) the below work with X-Mouse Button Control works just great, and is also system wide.Download X-Mouse Button ControlIn the main window go to 'Layer 2' and change 'Wheel Up' and 'Wheel Down' to 'Scroll Windows Right' and 'Scroll Window Left'Go into the 'Settings > Modifier Keys Tab' and select 'Shift' for the 'Activate Layer 2' setting.Now in whatever active window, including Eclipse pressing shift and then scrolling up and down will scroll horizontally. If this has helped you feel free to follow me on Google+ or on twitter @danielsokolow.Update: I have been using this approach for a few days now and noticed that not all windows are horizontal scroll…

Eclipse ANT <Input> task "java.lang.NullPointerException"

ANT build fails with NullPointerException on the <input> tag. This error drove me crazy and took me longer than I would like to admit to figure out - the solution was to run the ANT script "in the same JRE as the workspace". There is an eclipse open Bug 281837 from 2009 but without any follow up so perhaps do add your comment/vote there to create some traction. To change the JRE setting right click on the ant script and choose "Run As > Ant Build... > JRE tab". If this has helped feel free to follow me on twitter @danielsokolows.